DJ Image Slider Version 4.4 bug

DJ Image Slider Version 4.4 bug

On PHP 8.0 and Joomla 4.2.2, an upgrade to Version 4.4 will crash your site IF (and only if) your site uses links from images.  The solution is to not upgrade.  My sites are on PHP 8.0 and work - compatibility with PHP 8 is the stated reason for the upgrade.  The error message in the error log on one site was: 
[10-Sep-2022 20:10:42 UTC] PHP Warning:  require_once(/home/nfscan65/public_html/components/com_content/helpers/route.php): Failed to open stream: No such file or directory in /home/nfscan65/public_html/modules/mod_djimageslider/helper.php on line 166  Despite being classified as a warning, the site crashed until I reverted to an earlier version.