Php 8.1 error

Php 8.1 error

Our joomla version is Joomla! 3.10.11. We have to update to php version 8.1. When doing so we get a warning:

imagepalettetotruecolor(): Argument #1 ($image) must be of type GdImage, bool given

Any idea's to quickly fix this problem?

We are using version 1.1 of the DJ-WebP. Downloading the latest version is not possible as we get an Error:

The application has stopped responding
Please contact the administrator of the site and let them know of this error and what you were doing when this happened.

Please help